Crashes on 10.5 Leopard

Something changed in the OS X 10.5 javascript engine, and the program ‘crashes’ and doesn’t run. It appears to have something to do with scope and closures, if anybody could tell me what changed.

Resolved 1.0.2: Handling of scope and closures changed in the newer versions of WebKit (OS X 10.5, Safari 3.1.1), which prevented the widget from running. Thankfully there was only one point that aggravated this feature, and it has been removed.