Package is now named "Disk Clock"

Resolved 0.9: Package is now named “Disk Clock”; the contraction of “Disc Clock” to DisClock never really got very far, though it’s still convenient for some space-adverse filenames